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IT Essentials 5.0
5.3.7.4 Lab - Run Line Utilities in Windows 7

Introduction
Print and complete this lab.

In this lab, you will use Windows Run line utilities to access and use tools to configure settings in Windows 7.

Recommended Equipment
The following equipment is required for this exercise:
» A computer running Windows 7

Step 1
Navigate to the “Run” window by clicking Start > Run. Type mmc and click OK.
If the “User Account Control” window appears, click Yes.

Do )

= Type the name of a program, folder, document, or Internet

—  resource, and Windows will open it for you.

Open: rmmc -

| ok b‘_H Cancel | | Browse..

Step 2
The “Consolel - [Console Root]” (console number may vary) window opens.

| 4 Consolel - [Console Root

ﬁ File Action View Favorites Window Help EEE

e =18
ol J MName Actions
There are no items to show in this view. Cun_snle g -
More Actions »
- .
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Step 3

To build your own custom console, click File > Add/Remove Snap-in.

You can select snap-ins for this console from those available on your computer and configure the selected set of snap-ins. For
extensible snap-ins, you can configure which extensions are enabled.

Available snap-ins:

Snap-n

m  ActiveX Control
&4 Authorization Manager
M Certificates

=, Component Services
&I'Compuher Managem...
é Device Manager

=¥ Disk Management

| Folder

=] Group Policy Obiject ...
&, 1P Security Monitar
&, 1P Security Policy M...
=] Link to Web Address

L SN -

Vendaor

Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft and...
Microsoft Cor...
Microsoft Cor. ..
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...

m

) e

Description:

Selected snap-ins:

| console Root

Edit Extensions...

Remove

Mowve Up

Move Down

The ActiveX Control snap-in enaBIes you to add .an MMC node with a results view containing an ActiveX control.

You can select snap-ins for this console from those available on your computer and configure the selected set of snap-ins. For
extensible snap-ns, you can configure which extensions are enabled.

Available snap-ins:

Snap-n

= ActiveX Control
Authorization Manager
I_r'jl Certificates

i, Component Services
(& computer Managem. ..
=4 Device Manager

1= Disk Management
Event Viewer

[ Folder |

_Ej Group Policy Object ...
3, 1P Security Monitar

Vendor

Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft and...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...
Microsoft Cor...

m

@. IP Security Policy M...  Microsoft Cor...

|| Link to Web Address ~ Microsoft Cor...  _

L SN el wto dis ~
Description:

Selected snap-ins:

[] Console Root

The Folder snap-in adds a folder node to ﬁe tree. Tﬁis can be used .to organize your snap-n console.

Edit Extensions...

Remove

Move Up

Move Down

To add a folder snap-in so that you can organize all your snap-ins, scroll down until you see the Folder
shap-in. Select Folder > click Add.
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To add the “Link to Web Address” snap-in, scroll down until you see the snap-in. Select Link to Web
Address > click Add. The “Link to Web Address” wizard opens. In the Target box type
http://www.cisco.com.

. :
Link to Web Address |

Welcome to the Link to Web Address
Wizard

The Link to Web Address snap-n consists of an MMC
node with a Web page in the results view. Type the
path ar URL for the site you want to display, or dick
Browse,

Path or URL:

http:/fwww. disco.com

Browse...

< Back [ Mext = %J [ Cancel

L A

Click Next.

In the “Friendly name for the Link to Web Address snap-in” box, type Cisco.

(I —— '_E"‘

Friendly name for the Link to Web Address snap-in:

Cisco

< Back ][ Finish %J [ Cancel

- ’

Click Finish.
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Step 4

To add snap-ins to the folder snap-in, click Advanced.

You can select snap-ins for this console from those available on your computer and configure the selected set of snap-ins. For
extensible snap-ins, you can configure which extensions are enabled.

Available snap-ins: Selected snap-ins:
Snap-in Vendor -~ [ console Roat Edit Extensions. ..
I Folder

o Component Services Microsoft Cor...

$=Cnmpuher Managem... Microsoft Cor... F =] Cisco Kemples
:éDevicE Manager Microsoft Cor...
155 Disk Management Microsoft and... Move Up I
QEuent Viewer Microsoft Cor... |
Move Down

=]
[IFolder Microsoft Cor...

_%J' Group Policy Object ... Microsoft Cor...
\gIP Security Monitor Microsoft Cor... —
\gIP Security Policy M...  Microsoft Cor...
| Link to Web Address  Microsoft Cor...
&\ ocal Users and Gro...  Microsoft Cor...
2| NAP Client Configur... Microsoft Cor...

@Parhrmance Monitor  Microsoft Cor...  _ Advanced. ., k

Description:
The Link to Web Address snap-in enables you to add an MMC node with a Web page in the results view.

i
|
— —

Check the box next to Allow changing the parent snap-in.

' ™
Advanced @

By default, snap-ins are added under the console root node. Selecting this check box
enables you to choose the parent snap-in under which snap-ins will be added.

Allow changing the parent snap-in

[ 0K %‘H Cancel

Click OK.

A drop-down menu appears for “Parent snap-in”.

You can select snap-ins for this console from those available on your computer and configure the selected set of snap-ins. For
extensible snap-ins, you can configure which extensions are enabled,

Available snap-ins: Parent snap-in:
Snap-in ‘endor & [ | Console Root 'J
. Component Services  Microsoft Cor. . || Console Root
o onogen.. MomofiCr.. Er—
&= Device Manager Microsoft Cor... == Fider
5§ Disk Management Microsoft and... = Ciacn SEae I
QEvant Viewer Microsoft Cor.., |~ =
I Folder Microsoft Cor...
=/ Group Policy Object ... Microsoft Cor... i e
.g IP Security Monitor Microsoft Cor... — Move Down
.g 1P Security Policy M...  Microsoft Cor...
|=|Link to Web Address ~ Microsoft Cor...
&-Loml Users and Gra... Microsoft Cor...
NAP Client Configur... Microsoft Cor...
'@)Perfwmance Monitor ~ Microsoft Cor...  _ Advanced...
el e rE

Description:

The Link to Web Address snap-in enables you to add an MMC node with a Web page in the results view.

'

In the “Parent snap-in” box, select Folder.
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Add the following snap-ins: Computer Management, Device Manager, and Disk Management.

Note: When you are asked what computer the snap-in will manage, select the default by clicking Finish.
Click OK to accept all changes.

‘fou can select snap-ns for this console from those available on your computer and configure the selected set of snap-ins. For
extensible snap-ins, you can configure which extensions are enabled.

Available snap-ins: Parent snap-in:
Snap-n Vendor 2 | Folder ~ ]
:"-b_ Component Services  Microsoft Cor... Selected snap-ns:
‘% CompieriManagem:zs) Mimsoft Corey | console Root Edit Extensions...
g=x Device Manager Microsoft Cor... = Folder
=7 Disk Management Microsoftand... | ) _;é"Computer Management (Loc e |
] Event viewer Microsoft Cor... |~

=k Device Manager on local cor,

| Folder Microsoft Cor... i .
— Add = Disk Management{Local) Move |
=/ Group Policy Object . = Move Up

.. Microsoft Cor... =
2] Cisco
@ IP Security Monitor Microsoft Cor,.. —
@ 1P Security Policy M...  Microsoft Cor...
|2 Link to Web Address  Microsoft Cor...
A\ ocal Users and Gro...  Microsoft Cor...
2=| NAP Client Configur... Microsoft Cor...

:@)PerfﬁrmanceMonitor Microsoft Cor...  _ < m ] b

Description:

Maove Down

Dynamic disk and volume management provided to Microsoft by VERITAS Software Corporation.

L

Step 5

The “Consolel” window appears. Right-click the Folder icon and select Rename. Change the name of the
folder to “Management Tools”.

File Action View Favorites Window Help - [=]=
=2 |E =]

~ Console Root Name Action

4 | Management Tools ~[re———— s =

» & Computer Management (Local)
» &) Device Manager on local comput|
» k=4 Disk Management(Local)

| Cisco

=] Cisco More Actions

To save the custom console, click File > Save As. Change the file name to your name. Example: John’s
Console. Change the “Save in” box to Desktop. Click Save.

Step 6
Close all open windows.

On the desktop, double-click the Console icon to re-open the console with your snap-ins.
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Step 7
Open the “Choose your desktop background” page in Personalize appearance and sounds by right-
clicking the Desktop > Personalize > Desktop Background.

What is the Background picture?

Click the Picture location drop-down button and select Solid Colors. Select a blue color.

K ol )| & < Personalization » Deskiop Background = |43 l| Search Controt Panel »|

Choose your desktop background

Click a picture to make it your desktop background, or select mare than ane picture to create 3 slide show.

Picture location: [Solid Colors =] [ Browse... |

-

Click Save changes.

The computer screen should now have a blue background. If not, ask the instructor for assistance.

Step 8
Open Registry Editor by clicking Start > Run > type regedit > click OK.

If the “User Account Control” window appears, click Yes.

Note: Do not make any changes in the Registry Editor without instructor permission.

PR Regisiry Editor

File Edit View Favorites Help

4 /M Computer Name Type Data
+ .}y HKEY_CLASSES ROOT
- |1 HKEY_CURRENT_USER
b | HKEV_LOCAL_MACHINE
-} HKEV_USERS
- |. HKEY_CURRENT_CONFIG

Computer

Click the HKEY_CURRENT_USER icon.
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File Edit View Favorites Help

4 /% Computer Name Type Data

b~ HKEY_CLASSES ROOT 28] (Default) REG_SZ fwalue not set)
b HKEY_CURREMT_USER
b HKEY_LOCAL_MACHINE
L e uses - =)
>+ 4 HKEY_CURRENT_CONFIG
Find what:  Background Find Mext k
ok
Keys
Values
Data
[] Match whole string only

Computer\HKEY_CURRENT_UISER

To search for the desktop Background key, click Edit > Find > type Background > click Find Next.

The Background value is located. Leave this window open.

[ Regisiry Editor

File Edit View Favorites Help

Console || Mame Type Data 5 I
4- Control Panel 25) (Default) REG_SZ (value not set)
>l Accessibility || 28] ActiveBorder REG_S7 180 180 180
i ?:r;ira"ce 5] ActiveTitle REG_SZ 1532180 209 L
Liciar 1 ‘,b]AppWorkspa:e REG_SZ 1711711171
o 1l Destion E REG_SZ 1059118
> B Infrared 2B|ButtonAltemnate... REG_SZ 000
Input Method ab]ButtonDkShadew  REG_SZ 105105 105
| Internstional || 2%]ButtonFace REG 57 240 240 240
Keyboard a5|Buttonkilight ~ REG_SZ 255 255 255
Mause ab] ButtonLight REG_S7 237 237 237
Personalization 5|ButtonShadow  REG SZ 160 160 160
| PowerCfg 5] ButtonText REG_SZ 000
Sound _ || 2B GradientactiveT... REG_SZ 185 200 234 o
< i ] » f’] 1. ] »
ComputerHKEY_CURRENT_USER\Control Panel\Colors

In which folder is the Background located?

What is the data value of the Background (hint — it has three numbers that correspond to red, green, and
blue)? Answers may vary based on the shade of blue selected in Choose your desktop background.

Step 9
We will now export the HKEY_CURRENT_USER\Control Panel\Colors folder.
In the left pane, click the Colors folder.
Click File > Export. Save the file to the Desktop with the name BlueBKG.

At the desktop, right-click the BlueBKG.reg icon > Edit.
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L

File Edit Format View Help
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel‘Colors]
| "Background"="10 59 118"
"scrollbar"="200 200 200"
"ActiveTitle"="153 180 209"
"InactiveTitle"="191 205 219"
"Menu'="240 240 240"
"window"="255 255 255"
"wWindowFrame"="100 100 100"
"MenuText"="0 0 0"
"windowText
"TitleText"” oo
i "="180 180 180"
244 247 252"
“Ap?workspace“= 171 171 1717
"Hilight"="51 153 255"
"HilightText"="255 255 255"
"ButtonFace'="240 240 240"
"puttonshadow”="160 160 160"
"GrayText"="109 109 109"
"ButtonText"'="0 0 0"
"InactiveTitleText"="67 78 84"
"ButtonHilight"="255 255 253"
"ButtonDkShadow"="105 105 105"
“ButtonLight”=“22? 227 227"
"nfoText"="0 0 0"
"Infowindow''="255 255 225"
"ButtonAlternateFace"="0 0 0"
"HotTrackingColor"="0 102 204"
"GradientAactiveTitle ="185 209 234"
"GradientInactiveTitle"="215 228 242"
"MenuHilight"="51 153 255"
"MenuBar "="240 240 240"

Pt

What is the data value of the Background? Answers may vary based on the shade of blue selected in
Display Properties.

Close the BlueBKG.reg — Notepad window.

Step 1gpen the “Choose your desktop background” page in Personalize appearance and sounds by right-
clicking the Desktop > Personalize > Desktop Background.
Click the Location drop-down button and select Solid Colors. Select a red color.
Click Save changes.
In a few seconds, the desktop will turn to red.

Click the Registry Editor window so it is activated.

On your keyboard, press F5 to refresh the “Registry Editor” window.
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Registry Editor

File Edit View Favorites Help

" ! Consale “ || Name Type Data
4\ Contol Panel 2b] (Default) REG_SZ (value not set)
: ﬁ;;‘:{':;"::r a8 ActiveBorder REG_SZ 180180 180
T ab| ActiveTitle REG_SZ 153 180 209
3 e E_?JAppWDrkspace REG_SZ 171171171
i | Desktop 3_‘_'] Background REG_SZ 184 40 50
b Infrared ab| ButtonAlternate.. REG_SZ 000
> Input Method ab] ButtonDkShadow  REG_SZ 105105105
| International ab| ButtonFace REG_SZ 240 240 240
| Keyboard 35| ButtonHilight ~ REG_SZ 255 255 255
B} Mouse 5] ButtonLight REG_SZ 227 227 227
b -_ Personalization ab| ButtonShadow REG_SZ 160 160 160
|| PowerCfg 2b] ButtonText REG_SZ 000
ab| GradientActiveT... REG_SZ 185 209 234

| » 4-| T

Computer\HKEY_CURRENT_USER\Control Panel\Colors

What is the data value of the Background? Answers may vary based on the shade of red selected in
Display Properties.

Step 11
We will now import BlueBKG.reqg file.
Click the “Registry Editor” window so it is activated.
Click File > Import. Locate and click the BlueBKG.reg icon then click Open.

Click OK.

File Edit View Favorites Help

i Console “ || Name Type Data
4\ Contol Panel 2b] (Default) REG_SZ (value not set)
b+l Accessibility 25| ActiveBorder REG_SZ 180180180
>+l Appearance ab) ActiveTitle REG_SZ 153180 200
f,‘_']AppWorkspace REG_SZ 17117117
| Desktop 3_‘_'] Background REG_SZ 1059118
. . Infrared ab| ButtonAlternate.. REG_SZ 000
| Input Method ab] ButtonDkShadow  REG_SZ 105105105
.| International ab| ButtonFace REG_SZ 240 240 240
| Keyboard 35| ButtonHilight ~ REG_SZ 255 255 255
Mouse ab] ButtonLight REG_SZ 227 227 227
. Personalization ab| ButtonShadow REG_SZ 160 160 160
| Power(Cfg ab| ButtonText REG_SZ 000
ab| GradientActiveT... REG_SZ 185 209 234

Colors
Cursors

| » q | 1

Computer\HKEY_CURRENT_USER\Control Panel\Colors

Click the Registry Editor window so it is activated.
What is the data value of the Background? Answers may vary based on the shade of blue selected in

Display Properties.

What is the color of the desktop?
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Restart the computer.
What is the color of the desktop?

Reset Display Properties Background to the original settings (hint — see Step 7).

Step 12
Open the Run dialog box by clicking Start, and in the Search programs and files box, type Run and press

Enter.

Type the name of a program, folder, document, or Internet
resource, and Windows will cpen it for you,

Open: cleanmgr

Cancel ] ’ Browse...

Type cleanmgr in the “Open:” field.
Click OK.

The “Disk Cleanup” window opens and calculates available free space.

[ Disk Cleanup - i gw

Digk Cleanup is calculating how much space you will be
e abletofree on (C:). This may take a few minutes to
complete.

Calculating...
—_— I [ Cancel ]

‘ Scanning: System emor memony dump files

The “Disk Cleanup for (C:)” window opens.
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p =
Dizk Cleanup

You can use Disk Cleanup to free up to 2.76 MB of disk
space on ().

Files to delete:

.. Downloaded Program Files
=) Temporary Intemet Files
] E Recycle Bin
] || Setup Log Files
] || Temporary files

=

Total amourt of disk space you gain:
Description

Files used for emor reporting and solution checking.

[ I@"[ﬂean up system files ]

How does Disk Cleanup worc?

Make sure only Downloaded Program Files and Temporary Internet Files are selected.
Click the OK button.

Why should disk cleanup be performed regularly?
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